Singa Check-in

Minor incident Business Check-In
2024-08-24 00:04 EEST · 21 minuter, 24 sekunder

Updates

Resolved

All services operational again.

augusti 24, 2024 · 00:25 EEST
Monitoring

A fix has been released, we are monitoring the status.

augusti 24, 2024 · 00:11 EEST
Issue

Some of our customers are experiencing technical issues. Our team is working hard to resolve this issue quickly. We’re truly sorry if this has interrupted your karaoke in any way. Thank you for your patience and we’ll keep updating you on the progress.

augusti 23, 2024 · 23:00 EEST

← Back