Problems with Check-In

Minor incident Business Check-In
2023-01-12 18:53 EET · 32 minutes

Updates

Resolved

Problem solved

January 12, 2023 · 19:25 EET
Issue

Some of our customers are experiencing technical issues. Our team is working hard to resolve this issue quickly. We’re truly sorry if this has interrupted your karaoke in any way. Thank you for your patience and we’ll keep updating you on the progress.

January 12, 2023 · 19:01 EET

← Back